Opened 8 years ago

Last modified 8 years ago

defect #102 (closed: duplicate)

Problem with Iterations View

Test Complete Size: 0 Test Complete Date:
Documentation Complete Size: 0 Documentation Complete Date:
Acceptance Complete Size: 0 Acceptance Complete Date:
Reported by: samhamilton Owned by: ja11sop
Milestone: Clean up of Plugin with Patch Component: agiletracplugin
Version: Keywords:
Cc: Blocked By:
Blocking: Patch SVN Revision: 275
Patch Trac Version: 0.11.2
In Iterations: 21

Description

When clicking iterations view i get the following error:

Trac detected an internal error: TypeError?: sequence item 0: expected string, NoneType? found

&

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 432, in _dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 204, in dispatch

resp = chosen_handler.process_request(req)

File "/usr/lib/python2.4/site-packages/trac/ticket/roadmap.py", line 380, in process_request

iteration_info = TicketSystem?(self.env).get_iteration_info(iteration, req, self.stats_provider)

File "/usr/lib/python2.4/site-packages/trac/ticket/api.py", line 665, in get_iteration_info

milestone_sizing_stats = self.get_sizing_statistics_for_milestones(milestones)

File "/usr/lib/python2.4/site-packages/trac/ticket/api.py", line 438, in get_sizing_statistics_for_milestones

cursor.execute("SELECT tc.ticket,tc.stage,tc.size FROM ticket_completion tc, ticket t WHERE tc.ticket = t.id AND t.milestone IN (\'%s\')" %

Any idea how to fix it?

Change History

Have a look at the list of modified files related to this ticket.

Changed 8 years ago by ja11sop

  • test_complete_size changed from undefined to 3
  • doc_complete_size changed from undefined to 0
  • acceptance_complete_size changed from undefined to 1

Thanks for raising the issue - it looks like this might be related to recent changes made to support postgresql 8.3. Are you by any chance using sqlite as the backend database? Moving this to the clean-up milestone.

Changed 8 years ago by ja11sop

  • status changed from sized to closed
  • test_complete_size changed from 3 to 0
  • resolution set to duplicate
  • acceptance_complete_size changed from 1 to 0

This appears to be a duplicate of #91

Note: See TracTickets for help on using tickets.