Opened 10 years ago

Last modified 10 years ago

user story #103 (closed: duplicate)

How to Customize the stages

Test Complete Size: 0 Test Complete Date:
Documentation Complete Size: 0 Documentation Complete Date:
Acceptance Complete Size: 0 Acceptance Complete Date:
Reported by: rpkelley Owned by: ja11sop
Milestone: Clean up of Plugin with Patch Component: ticket enhancements
Version: Keywords:
Cc: Blocked By:
Blocking: Patch SVN Revision:
Patch Trac Version: not_applicable
In Iterations: 21 23

Description

I have successfully installed your plugin and I must say, nice work. I am not clear on exactly what everything is, and I have a few quetions.

1. What are the "Sizes" for your stages, Test, Documentation, and Acceptance ? Are these just aggregate values that make up the total ticket size? So those numbers together, say 10 10 and 20 make a ticket size of 40? so then an 80 is bigger than a 40? Or is all this used for metrices in the roadmap and iteration views?

2. How can I customize/ Add/ Remove my own stages. So say I have the stages in my actual process of Analysis --> Dev/Test? --> Design --> QA/Test --> Deploy --> Done

Is there a way to do this?

Change History

Have a look at the list of modified files related to this ticket.

Changed 10 years ago by ja11sop

The best place to start regarding the fundamentals of how to use the plugin (beyond the sparse documentation page) is the Foundations of agile development blog entry. Referring more specifically to your query though regarding the use of 'stages'. The key point is that the total effort associated with a story is the sum of the stages. In an ideal world you'd only have one as Doc and QA would be an integral part of the development effort, but in practice they often aren't so it helps to be able to make that separation. The association of stories to iterations allows metrics to be collected that provides an opportunity to assess likely future completion times for milestones. There is a spreadsheet on the documentation page that provides an insight into how that is done. Also, you are right, bigger is more.

The basic idea is that you 'progress' a ticket by entering a completion date for each stage. When all stages are progressed to 'complete' then the ticket is automatically resolved as 'DONE'. As stories are DONE in an iteration the points per iteration (which has a defined time period) are then tallied up and and average across previous iterations is used to estimate future progress.

It is possible to customise the stages. Having a look at the format used for the default three stages in your trac.ini file should shed enough light on how to do this. We are actually currently working on a couple of patches to ensure this works as expected and will at the same time update the documentation page to provide more complete instructions on how you should go about this. Apologies for the short answer but I hope it is enough to get you going. Reading the blog entry and associated pdf should provide a much greater insight.

Changed 10 years ago by rpkelley

Thank you for the implementation, I am looking forward to seeing what you guys continue to release.

Which trac.ini file are you referring to? The one that is in the conf folder of the trac instance? or is there another one?

I see this section in my trac.ini (in my trac instance)

[ticket-completion] acceptance_complete = acceptance_complete.label = Acceptance Complete acceptance_complete.order = 3 acceptance_complete.short_label = Acceptance doc_complete = doc_complete.label = Documentation Complete doc_complete.order = 2 doc_complete.short_label = Documented test_complete = test_complete.label = Test Complete test_complete.order = 1 test_complete.short_label = Tested

Is this where you would add or rename stages?

Changed 10 years ago by ja11sop

Related to #105

Changed 10 years ago by ja11sop

  • status changed from new to closed
  • test_complete_size changed from undefined to 0
  • resolution set to duplicate
  • doc_complete_size changed from undefined to 0
  • acceptance_complete_size changed from undefined to 0

Apologies for not getting back to you sooner about this. You are correct. In order to change your stages you simple edit your conf/trac.ini file. I have updated the documentation to describe this in more detail in the section Customising Completion Stages. I'm resolving this as a duplicate of #105. I hope the new documentation makes things clear for you.

Changed 10 years ago by ja11sop

  • milestone changed from Undecided to Clean up of Plugin with Patch
Note: See TracTickets for help on using tickets.