Opened 10 years ago

Last modified 10 years ago

defect #53 (new)

EndUser? can't view tickets that existed before installation of the Agile Trac Plugin

Test Complete Size: undefined Test Complete Date:
Documentation Complete Size: undefined Documentation Complete Date:
Acceptance Complete Size: undefined Acceptance Complete Date:
Reported by: antonio.alonso Owned by: ja11sop
Milestone: Undecided Component: completion stages
Version: Keywords:
Cc: Blocked By:
Blocking: Patch SVN Revision:
Patch Trac Version:
In Iterations: None

Description

Hi there,

I was testing some kind of plugins for adding planning and estimation information to the tickets. When I installed your plugin, everything work well (at a first glance), I could create new tickets.

But when I tried to take a look to some old tickets, created before the plugin was installed, I found a problem, following is the error and its stacktrace:

Error

Trac detected an internal error:

AttributeError: 'TicketSystem' object has no attribute 'get_ticket_completion_stages'

Stacktrace

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/ticket/web_ui.py", line 170, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/ticket/web_ui.py", line 517, in _process_ticket_request
    get_reporter_id(req, 'author'), field_changes)
  File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/ticket/web_ui.py", line 1210, in _insert_ticket_data
    label, widget, hint = controller.render_ticket_action_control(
  File "build/bdist.linux-i686/egg/agiletrac/workflow.py", line 391, in render_ticket_action_control

Regards

Change History

Have a look at the list of modified files related to this ticket.

Changed 10 years ago by ja11sop

Thanks for the stack trace. Yes, let me think about how to address this. One of the problems will be migrating existing trac installs. I have not actually tried too hard to deal with this. I'll have a look at this in case there is an easy fix and update the ticket again soon.

Silly question I know but is the plugin enabled?

Changed 10 years ago by ja11sop

Changed 10 years ago by antonio.alonso

Thanks for your response.

Yes, the plugin is enabled. I have noticed that if I disable the plugin I can load the old tickets but, if I enable it again, the above error appears.

Changed 10 years ago by ja11sop

I'll try to look at this over the next couple of days. There may be an easy fix that allows upgrading an existing trac install (tickets and all) to use agile-trac. At the least there should be a suitable warning.

Changed 10 years ago by ja11sop

Note: See TracTickets for help on using tickets.