Opened 9 years ago

Last modified 9 years ago

user story #62 (closed: duplicate)

Error on Roadmap

Test Complete Size: 0 Test Complete Date:
Documentation Complete Size: 0 Documentation Complete Date:
Acceptance Complete Size: 0 Acceptance Complete Date:
Reported by: glaporte Owned by: ja11sop
Milestone: Clean up of Plugin with Patch Component: agiletrac patch to core
Version: Keywords:
Cc: Blocked By:
Blocking: Patch SVN Revision:
Patch Trac Version:
In Iterations: 15

Description

After installing the Agile-Trac plugin, I get that error message on RoadMap?.

Trac detected an internal error:

DatabaseError?: ORDER BY terms must not be non-integer constants

System Information:

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3 Trac: 0.11.1 Python: 2.4.3 (#1, Jun 13 2006, 16:41:18) [GCC 4.0.2 20051125 (Red Hat 4.0.2-8)] setuptools: 0.6c9 SQLite: 3.1.2 pysqlite: 1.1.6 Genshi: 0.5.1 mod_python: < 3.2 jQuery: 1.2.6

Change History

Have a look at the list of modified files related to this ticket.

  Changed 9 years ago by glaporte

Python Traceback Most recent call last:

  • File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request Code fragment:
    1. try:
    2. if not env and env_error:
    3. raise HTTPInternalError(env_error)
    4. try:
    5. dispatcher = RequestDispatcher?(env)
    6. dispatcher.dispatch(req)
    7. except RequestDone?:
    8. pass
    9. resp = req._response or []
    10. except HTTPException, e:
  • Local variables: Name Value after [u' except RequestDone:', u' pass', u' resp = ... before [u' try:', u' if not env and env_error:', u' raise ... dispatcher <trac.web.main.RequestDispatcher? object at 0xb5f7540c> e <_sqlite.DatabaseError? instance at 0xb5f75e4c> env <trac.env.Environment object at 0xb630404c> env_error None exc_info (<class _sqlite.DatabaseError? at 0xb600bf5c>, <_sqlite.DatabaseError? ... filename '/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py' frames [{'function': '_dispatch_request', 'lines_before': [u' try:', u' ... has_admin True line u' dispatcher.dispatch(req)' lineno 422 message u'DatabaseError?: ORDER BY terms must not be non-integer constants' req <Request "GET u'/roadmap'"> resp [] tb <traceback object at 0xb5f78694> tb_hide None traceback 'Traceback (most recent call last):\n File ...
  • File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/web/main.py", line 197, in dispatch Code fragment:
    1. req.args.get('FORM_TOKEN') != req.form_token:
    2. raise HTTPBadRequest('Missing or invalid form token. '
    3. 'Do you have cookies enabled?')
    4. # Process the request and render the template
    5. resp = chosen_handler.process_request(req)
    6. if resp:
    7. if len(resp) == 2: # Clearsilver
    8. chrome.populate_hdf(req)
    9. template, content_type = \
    10. self._post_process_request(req, *resp)
  • Local variables: Name Value chosen_handler <trac.ticket.roadmap.RoadmapModule? object at 0xb5f756cc> chrome <trac.web.chrome.Chrome object at 0xb600c9cc> err (<class _sqlite.DatabaseError? at 0xb600bf5c>, <_sqlite.DatabaseError? ... handler <trac.ticket.roadmap.RoadmapModule? object at 0xb5f756cc> req <Request "GET u'/roadmap'"> self <trac.web.main.RequestDispatcher? object at 0xb5f7540c>
  • File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/ticket/roadmap.py", line 756, in process_request Code fragment:
    1. # range
    2. expected_completion_dates = []
    3. for milestone in milestones:
    4. tickets = get_tickets_for_milestone(self.env, db, milestone.name,
    5. 'owner')
    6. tickets = TicketSystem?(self.env).apply_ticket_permissions(req, tickets)
    7. milestone_sizing_stats = TicketSystem?(self.env).get_sizing_statistics_for_milestones([milestone.name])
    8. stat = get_ticket_stats(self.stats_provider, tickets, milestone_sizing_stats, None)
    9. stats.append(milestone_stats_data(req, stat, milestone.name))
  • Local variables: Name Value db <trac.db.pool.PooledConnection? object at 0xb5f75f8c> expected_completion_dates [] m <trac.ticket.model.Milestone object at 0xb5f75e0c> milestone <trac.ticket.model.Milestone object at 0xb5f75f4c> milestone_realm <Resource 'milestone'> milestones [<trac.ticket.model.Milestone object at 0xb5f75f4c>, ... now datetime.datetime(2008, 10, 20, 10, 4, 47, 460660, tzinfo=<FixedOffset? ... points_per_period {'points': 0, 'period': datetime.timedelta(0)} queries [] req <Request "GET u'/roadmap'"> rolling_date datetime.datetime(2008, 10, 20, 10, 4, 47, 460660, tzinfo=<FixedOffset? ... self <trac.ticket.roadmap.RoadmapModule? object at 0xb5f756cc> showall False stats [] ticket_infos []
  • File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/ticket/roadmap.py", line 309, in get_tickets_for_milestone Code fragment:
    1. def get_tickets_for_milestone(env, db, milestone, field='component'):
    2. from trac.ticket import Ticket
    3. tickets = []
    4. cursor = db.cursor()
    5. cursor.execute("SELECT id FROM ticket WHERE milestone=%s "
    6. "ORDER BY %s", (milestone,field))
    7. ticket_ids = [str(row[0]) for row in cursor]
    8. for ticket_id in ticket_ids:
    9. ticket = Ticket(env, ticket_id, db)
    10. if ticket.exists:
    11. tickets.append(ticket)
  • Local variables: Name Value Ticket <class 'trac.ticket.model.Ticket'> cursor <trac.db.util.IterableCursor? object at 0xb5f736d4> db <trac.db.pool.PooledConnection? object at 0xb5f75f8c> env <trac.env.Environment object at 0xb630404c> field 'owner' milestone u'milestone1' tickets []
  • File "/usr/lib/python2.4/site-packages/Trac-0.11.1-py2.4.egg/trac/db/util.py", line 50, in execute Code fragment:
    1. def execute(self, sql, args=None):
    2. # -- In case of SQL errors, uncomment the following 'print' statements
    3. # print 'execute', repr(sql)
    4. if args:
    5. # print repr(args)
    6. return self.cursor.execute(sql_escape_percent(sql), args)
    7. return self.cursor.execute(sql)
    8. def executemany(self, sql, args=None):
    9. # print 'executemany', repr(sql)
    10. if args:
  • Local variables: Name Value args (u'milestone1', 'owner') self <trac.db.util.IterableCursor? object at 0xb5f736d4> sql 'SELECT id FROM ticket WHERE milestone=%s ORDER BY %s'
  • File "/usr/src/build/539311-i386/install//usr/lib/python2.4/site-packages/sqlite/main.py", line 255, in execute Local variables: Name Value SQL 'SELECT id FROM ticket WHERE milestone=%s ORDER BY %s' parms ("'milestone1'", "'owner'") self <trac.db.sqlite_backend.SQLiteUnicodeCursor instance at 0xb5f75eec>

follow-up: ↓ 5   Changed 9 years ago by ja11sop

Can you please make sure that the agile-trac plugin is enabled in the trac.ini file as shown in AgileTracPluginInstall

  Changed 9 years ago by glaporte

I had checked the trac.ini and the agile-trac plugin is enabled.

  Changed 9 years ago by glaporte

It seems to be the same defect as #57

in reply to: ↑ 2 ; follow-up: ↓ 6   Changed 9 years ago by glaporte

Replying to ja11sop:

Can you please make sure that the agile-trac plugin is enabled in the trac.ini file as shown in AgileTracPluginInstall

I had checked the trac.ini and the agile-trac plugin is enabled. It seems to be the same defect as #57

in reply to: ↑ 5   Changed 9 years ago by jbr

Hi - I had the same error after a clean install per #57 but, after some digging, fixed it by upgrading my environment's version of sqlite3 and pysqlite2

  Changed 9 years ago by ja11sop

  • test_complete_size changed from undefined to 0
  • doc_complete_size changed from undefined to 0
  • acceptance_complete_size changed from undefined to 0

Yes this is a duplicate of #57. Closing this issue as a duplicate and will update #57 with a view to documenting your reported fix as a dependency. Thanks a lot for getting to the bottom of this.

Note: See TracTickets for help on using tickets.