Opened 8 years ago

Last modified 8 years ago

user story #80 (closed: duplicate)

Roadmap Error

Test Complete Size: 0 Test Complete Date:
Documentation Complete Size: 0 Documentation Complete Date:
Acceptance Complete Size: 0 Acceptance Complete Date:
Reported by: riceball Owned by: ja11sop
Milestone: Clean up of Plugin with Patch Component: agiletracplugin
Version: Keywords: KeyError
Cc: Blocked By:
Blocking: Patch SVN Revision:
Patch Trac Version:
In Iterations: 18

Description

KeyError?:

the reason i found : the status is None , the status_count is no any about this.

def get_ticket_group_stats(self, ticket_ids, milestone_sizing_stats, end_date): .....

if status == 'closed' and not stages[ticket_id]done?:

status = 'sized'

if status is None: # added by riceball

status = # added by riceball

Change History

Have a look at the list of modified files related to this ticket.

Changed 8 years ago by riceball

if status is None: # added by riceball

status = # added by riceball

Changed 8 years ago by riceball

if status is None: # added by riceball
    status = '' # added by riceball


Changed 8 years ago by ja11sop

  • test_complete_size changed from 100 to undefined
  • acceptance_complete_size changed from 100 to undefined

Changed 8 years ago by ja11sop

  • test_complete_size changed from undefined to 1
  • doc_complete_size changed from undefined to 0
  • acceptance_complete_size changed from undefined to 1

Thanks for raising the issue and providing a work-around. Can you perhaps help me out a bit more and provide me with the following information?

  • What agile-trac plugin version are you using? 0.1.4 or 0.1.5
  • What svn revision for the patch are you at?
  • What version of Trac are you using? 0.11, 0.11.1 or 0.11.2

More importantly I would like to know how you had a ticket with an empty status. I mean, what is the scenario for getting an ticket with an empty status?

Thanks for the patch. Some defensive coding will be good.

Changed 8 years ago by ja11sop

Changed 8 years ago by riceball

trac 0.11.2 agile-trac 0.1.5

the main reseaon is that some milestones has been created before enable agile-trac. so the similar errors would be occur on modifying old tickets: XXX_complete_size is none, but need be a number.

Changed 8 years ago by ja11sop

  • test_complete_size changed from 1 to 0
  • acceptance_complete_size changed from 1 to 0

I see - yes that explains it then. There is actually an open ticket #44 that covers this. I'll mark this as a duplicate of #44 that one and add a reference to your use case here. Basically there needs to be some additional information added for existing tickets and milestones. One of the open issues was how this should be done. I've a pretty good idea now of what makes sense and will see about implementing this very soon.

Note: See TracTickets for help on using tickets.